Supported Mongo Versions
Rocket.Chat currently requires MongoDB version 3.6 or higher. Support of MongoDB 3.2 will has been removed from Rocket.Chat 2.0.0 and MongoDB 3.4 has been removed from Rocket.Chat 4.x. We recommend using version 4.2.
Note Without mongodb version we can't ensure you are running a compatible version. If you are running your mongodb with auth enabled and an user different from admin you may need to grant permissions for this user to check cluster data. You can do it via mongo shell running the following command replacing the string YOUR_USER by the correct user\'s name:
1
db.runCommand({ grantRolesToUser: "YOUR_USER" , roles: [{role: "clusterMonitor", db: "admin"}]})
Copied!

Supported Storage Engines

The Storage engine recommended for Rocket.Chat is WiredTiger.
Last modified 4mo ago
Export as PDF
Copy link